Performance downgrade at Crowdin Enterprise

Incident Report for Crowdin

Resolved

All services are fully operational
Posted Oct 10, 2025 - 14:41 UTC

Investigating

We noticed unusual behavior on the project dashboard, and the API is working more slowly than usual. It's being investigated further by our development team.
Posted Oct 10, 2025 - 14:34 UTC
This incident affected: Crowdin Enterprise, Crowdin Enterprise EU, Crowdin API Enterprise, and Crowdin API Enterprise EU.