Downgraded performance of Crowdin and Crowdin Enterprise

Incident Report for Crowdin

Resolved

After thorough monitoring, we can confirm the service is fully back to normal. The incident has now been marked as "Resolved". We will continue to monitor Crowdin's health 24/7/365. Thank you!
Posted Mar 16, 2026 - 09:46 UTC

Monitoring

All services are back to the normal state. We will keep the incident open for the next 10 minutes to provide you with a final confirmation.
Posted Mar 16, 2026 - 09:31 UTC

Identified

The issue has been identified, and a solution is being implemented. As a temporary measure, users may encounter a CAPTCHA when navigating between pages.
Posted Mar 16, 2026 - 09:19 UTC

Investigating

We noticed unexpected service behavior, mainly crowdin.com is impacted. Our developers have already started investigating the case, and you will be posted on further updates.
Posted Mar 16, 2026 - 08:55 UTC
This incident affected: crowdin.com, Crowdin Enterprise, and Crowdin Enterprise EU.